益通网炒股平台_网上股票配资官网/益通网配资官网

益通网炒股平台_网上股票配资官网/益通网配资官网

通达信回马量化主图指标公式(附源码破译和源码)

发布日期:2024-04-25 10:27    点击次数:77

编程思路破译

输出历低价:当前值是近最低价周期的最小值,画淡青色 NODRAW

输出历高价:当前值是近最高价周期的最大值,画洋红色,NODRAW

输出历低量:当前值是近成交量(手)周期的最小值,画淡青色 NODRAW

输出历高量:当前值是近成交量(手)周期的最大值,画洋红色,NODRAW

NHL赋值:统计30日中满足上次收盘价的250日简单移动平均>1日前的收盘价的250日简单移动平均距今天数>=220的天数>=1 AND 上次收盘价的250日简单移动平均<=1日前的收盘价的250日简单移动平均距今天数>=1

输出NOTEXTQ:如果收盘价的250日简单移动平均>=1日前的收盘价的250日简单移动平均,返回收盘价的250日简单移动平均,否则返回无效数画红色 线宽为2

输出NOTEXTR:如果收盘价的250日简单移动平均<1日前的收盘价的250日简单移动平均,返回收盘价的250日简单移动平均,否则返回无效数画淡青色 线宽为2

输出NOTEXTD:如果统计30日中满足上次收盘价的250日简单移动平均>1日前的收盘价的250日简单移动平均距今天数>=220的天数>=1ANDBARSLAST(收盘价的250日简单移动平均<=1日前的收盘价的250日简单移动平均)>=1ANDMA(收盘价,20)>收盘价的250日简单移动平均,返回收盘价的250日简单移动平均,否则返回无效数画洋红色 线宽为5

NO2赋值:IKE('68')ORCODELIKE('30'),19.71,9.71)ANDC=HANDIF(成交量(手)的有效数据周期数位于20和250之间,统计8日中满足((收盘价/1日前的收盘价)-1)*100>如果模糊匹配品种代码ORCODELIKE('30'),返回19.71,否则返回9.71ANDC=最高价的天数=1日前的如果1日前的成交量(手)>=1日前的成交量(手)*1.87ANDC>=(1日前的收盘价,开盘价)ANDTOPRANGE(成交量(手))>=20ANDL>1日前的开盘价,返回1日前的开盘价,否则返回上次((收盘价/1日前的收盘价)-1)*100>如果品种代码,返回?,否则返回?的?日过滤距今天数日前的如果最低价>1日前的最高价,返回1日前的最高价,否则返回开盘价

NOD赋值:上次((收盘价/1日前的收盘价)-1)*100>如果模糊匹配品种代码ORCODELIKE('30'),返回19.71,否则返回9.71ANDC=HANDIF(成交量(手)的有效数据周期数位于20和250之间,统计?日中满足((收盘价/1日前的收盘价)-1)*100>如果模糊匹配品种代码,返回?,否则返回?的天数的?日过滤距今天数日前的如果1日前的最低价>2日前的最高价,返回2日前的最高价,否则返回NO2

K线

当满足条件1日前的开盘价时,在上次((收盘价/1日前的收盘价)-1)*100>如果模糊匹配品种代码ORCODELIKE('30'),返回19.71,否则返回9.71ANDC=HANDIF(成交量(手)的有效数据周期数位于20和250之间的?日过滤距今天数日前的如果1日前的最低价>2日前的最高价,返回2日前的最高价,否则返回NO2和统计8日中满足((收盘价/1日前的收盘价)-1)*100>如果模糊匹配品种代码ORCODELIKE('30'),返回19.71,否则返回9.71ANDC=最高价的天数=1,统计?日中满足((收盘价/1日前的收盘价)-1)*100>如果模糊匹配品种代码ORCODELIKE('30'),返回19.71,否则返回9.71AND的天数位置之间画柱状线,宽度为=最高价,20)=1AND(收盘价的20日简单移动平均上穿收盘价的250日简单移动平均ANDC/收盘价的250日简单移动平均<1.15ORCROSS(收盘价,收盘价的250日简单移动平均)))=1,5))),上次((收盘价/1日前的收盘价)-1)*100>如果模糊匹配品种代码ORCODELIKE('30'),返回19.71,否则返回9.71ANDC=HANDIF(成交量(手)的有效数据周期数位于20和250之间的?日过滤距今天数日前的如果1日前的最低价>2日前的最高价,返回2日前的最高价,否则返回NO2不为0则画空心柱.,COLOR404080

当满足条件最高价时,在上次当前值是近成交量(手)周期的最大值>=20ANDC<OANDL<=1日前的最高价的3日过滤距今天数日前的开盘价和上次当前值是近成交量(手)周期的最大值>=20ANDC<OANDL<=1日前的最高价的3日过滤距今天数日前的开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,画蓝色

当满足条件最高价时,在上次当前值是近成交量(手)周期的最大值>=20ANDC>=OANDC>=1日前的收盘价的1日过滤距今天数日前的收盘价和上次当前值是近成交量(手)周期的最大值>=20ANDC>=OANDC>=1日前的收盘价的1日过滤距今天数日前的收盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,画淡灰色

当满足条件成交量(手)>=1日前的成交量(手)*1.87ANDC>=(1日前的收盘价,开盘价)ANDTOPRANGE(成交量(手))>=20时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.画蓝色

当满足条件成交量(手)/1日前的成交量(手)>=2.9ANDC>=OANDTOPRANGE(成交量(手))>=20时,在开盘价和收盘价位置之间画柱状线,宽度为(-1),0不为0则画空心柱.画洋红色

当满足条件(收盘价-1日前的收盘价)/1日前的收盘价*100<如果模糊匹配品种代码,返回-9.0,否则返回-6.9AND(收盘价-1日前的收盘价)/1日前的收盘价*100<如果模糊匹配品种代码,返回-9.0,否则返回-6.9时,在开盘价和收盘价位置之间画柱状线,宽度为(-1),0不为0则画空心柱.,画绿色

当满足条件(收盘价/1日前的收盘价-1)*100<如果模糊匹配品种代码,返回-9.0,否则返回-6.9AND(收盘价-1日前的收盘价)/1日前的收盘价*100<如果模糊匹配品种代码,返回-9.0,否则返回-6.9ANDH<1日前的最低价时,在开盘价和收盘价位置之间画柱状线,宽度为(-1),0不为0则画空心柱.,画黑色

当满足条件(成交额(元)的1日累和/成交量(手)的1日累和/100>1日前的收盘价ANDC<=开盘价)OR(成交额(元)的1日累和/成交量(手)的1日累和/100>1日前的收盘价ANDC>1日前的收盘价ANDC<OANDC>300)ANDNOT((收盘价-1日前的收盘价)/1日前的收盘价*100>=9.71ANDO=收盘价)ANDN时,在T((收盘价-1日前的收盘价)/1日前的收盘价*100<=-9.71ANDO=收盘价)ANDNOT(((收盘价/1日前的收盘价)-1)*100>如果模糊匹配品种代码ORCODELIKE('30'),返回19.71,否则返回9.71ANDC=最高价)ORAMOUNT/成交量(手)/100<1日前的收盘价ANDC>OANDC<300A和DSUM(成交额(元),1)/成交量(手)的1日累和/100<1日前的收盘价ANDNOT((收盘价-1日前的收盘价)/1日前的收盘价*100>=9.71ANDO=收盘价)ANDNOT((收盘价-1日前的收盘价)/1日前的收盘价*100<=-9.71ANDO=收盘价)位置之间画柱状线,宽度为开盘价和收盘价的较小值,开盘价和收盘价的较小值+(开盘价和收盘价的较大值-开盘价和收盘价的较小值)*0.5不为0则画空心柱.COLORFF80FF

当满足条件((收盘价/1日前的收盘价)-1)*100>如果模糊匹配品种代码ORCODELIKE('30'),返回19.71,否则返回9.71ANDC=最高价时,在开盘价和收盘价位置之间画柱状线,宽度为(3),0不为0则画空心柱.画红色

当满足条件(开盘价-收盘价)/开盘价>0.02ANDC<1日前的收盘价时,在(收盘价+开盘价)/2和(收盘价+开盘价)/2位置之间画柱状线,宽度为2,1不为0则画空心柱.画青色

当满足条件(收盘价-开盘价)/开盘价>0.02ANDC>1日前的收盘价时,在(收盘价+开盘价)/2和(收盘价+开盘价)/2位置之间画柱状线,宽度为2,1不为0则画空心柱.画青色

当满足条件当前值是近成交量(手)周期的最大值>=88ANDC>开盘价时,在(收盘价和开盘价的较大值-收盘价和开盘价的较小值)*0.50+收盘价和开盘价的较小值和收盘价位置之间画柱状线,宽度为(-1),0不为0则画空心柱.COLOR4080FF

当满足条件(最高价-1日前的收盘价)/1日前的收盘价*100>如果模糊匹配品种代码,返回19.71,否则返回9.71AND(最高价-1日前的收盘价)/1日前的收盘价*100>如果模糊匹配品种代码,返回19.71,否则返回9.71ANDC<最高价时,在收盘价和开盘价的较大值和收盘价和开盘价的较大值*0.995位置之间画柱状线,宽度为(2),0不为0则画空心柱.画黑色

当满足条件((收盘价/1日前的收盘价)-1)*100>如果模糊匹配品种代码ORCODELIKE('30'),返回19.71,否则返回9.71ANDC=HANDIF(成交量(手)的有效数据周期数位于20和250之间,统计?日中满足((收盘价/1日前的收盘价)-1)*100>如果模糊匹配品种代码ORC,返回?,否则返回?的天数的?日过滤时,在DELIKE('30'),19.71,9.71)ANDC=最高价,8)=1,统计20日中满足((收盘价/1日前的收盘价)-1)*100>如果模糊匹配品种代码ORCODELIKE('30'),返回19.71,否则返回9.71ANDC=最高价的天数=1AND(收盘价的20日简单移动平均上穿收盘价的250日简单移动平均ANDC/收盘价的?日简单移动平均位置画50)<1.15ORCROSS(收盘价,收盘价的250日简单移动平均)))=1,5)号图标显示在位置之上

当满足条件上次当前值是近成交量(手)周期的最大值>=20ANDC<OANDL<=1日前的最高价的3日过滤距今天数日前的开盘价>0ANDCURRBARSCOUNT=1时,在上次当前值是近成交量(手)周期的最大值>=20ANDC<OANDL<=1日前的最高价的3日过滤距今天数日前的开盘价位置书写文字 显示在位置之上 画蓝色

当满足条件上次当前值是近成交量(手)周期的最大值>=20ANDC>=OANDC>=1日前的收盘价的1日过滤距今天数日前的收盘价>0ANDCURRBARSCOUNT=1时,在上次当前值是近成交量(手)周期的最大值>=20ANDC>=OANDC>=1日前的收盘价的1日过滤距今天数日前的收盘价位置书写文字 显示在位置之上 画淡洋红色

当满足条件上次当前值是近成交量(手)周期的最大值>=20ANDC<OANDL<=1日前的最高价的3日过滤距今天数日前的开盘价>0ANDCURRBARSCOUNT=1时,在上次当前值是近成交量(手)周期的最大值>=20ANDC<OANDL<=1日前的最高价的3日过滤距今天数日前的开盘价位置书写数字,画蓝色

当满足条件上次当前值是近成交量(手)周期的最大值>=20ANDC>=OANDC>=1日前的收盘价的1日过滤距今天数日前的收盘价>0ANDCURRBARSCOUNT=1时,在上次当前值是近成交量(手)周期的最大值>=20ANDC>=OANDC>=1日前的收盘价的1日过滤距今天数日前的收盘价位置书写数字,画淡洋红色

输出板底:如果到最后交易的周期<=?日前的上次((收盘价/1日前的收盘价)-1)*100>如果模糊匹配品种代码ORCODELIKE('30'),返回19.71,否则返回9.71ANDC=HANDIF(成交量(手)的有效数据周期数位于20和250之间,统计?日中满足((收盘价/1日前的收盘价)-的天数距今天数的最后一日取值设为常数,返回)*100>如果模糊匹配品种代码ORCODELIKE('30'),返回19.71,否则返回9.71ANDC=最高价,8)=1,统计20日中满足((收盘价/1日前的收盘价)-1)*100>如果模糊匹配品种代码ORCODELIKE('30'),返回19.71,否则返回9.71ANDC=最高价的天数=1AND(简单移动平均上穿?,否则返回收盘价,20),收盘价的250日简单移动平均)ANDC/收盘价的250日简单移动平均<1.15ORCROSS(收盘价,收盘价的250日简单移动平均)))),1)+1)+1,画洋红色,线宽为2

输出高阳:如果到最后交易的周期<=1日前的上次当前值是近成交量(手)周期的最大值>=20ANDC>=OANDC>=1日前的收盘价的1日过滤距今天数+1的最后一日取值设为常数+1,返回1日前的上次当前值是近成交量(手)周期的最大值>=20ANDC>=OANDC>=1日前的收盘价距今天数+1日前的上次当前值是近成交量(手)周期的最大值>=20ANDC>=OANDC>=1日前的收盘价的1日过滤距今天数日前的收盘价的最后一日取值设为常数,否则返回无效数,画红色,线宽为2

输出高阴:如果到最后交易的周期<=1日前的上次当前值是近成交量(手)周期的最大值>=20ANDC<OANDL<=1日前的最高价距今天数+1的最后一日取值设为常数+1,返回1日前的上次当前值是近成交量(手)周期的最大值>=20ANDC<OANDL<=1日前的最高价距今天数+1日前的上次当前值是近成交量(手)周期的最大值>=20ANDC<OANDL<=1日前的最高价的3日过滤距今天数日前的开盘价的最后一日取值设为常数,否则返回无效数,画蓝色 ,线宽为2

程序源码

{DRAWGBK(CLOSE>0,RGB(0,108,108),RGB(88,0,0),0,5,0);}

历低价:LOWRANGE(L),COLORLICYAN NODRAW;

历高价:TOPRANGE(H),COLORMAGENTA,NODRAW;

历低量:LOWRANGE(V),COLORLICYAN NODRAW;

历高量:TOPRANGE(V),COLORMAGENTA,NODRAW;

NHL:=COUNT(BARSLAST(MA(C,250)>REF(MA(C,250),1))>=220,30)>=1 AND BARSLAST(MA(C,250)<=REF(MA(C,250),1))>=1;

NOTEXTQ:IF(MA(C,250)>=REF(MA(C,250),1),MA(C,250),DRAWNULL)COLORRED LINETHICK2;

NOTEXTR:IF(MA(C,250)< REF(MA(C,250),1),MA(C,250),DRAWNULL)COLORLICYAN LINETHICK2;

NOTEXTD:IF(COUNT(BARSLAST(MA(C,250)>REF(MA(C,250),1))>=220,30)>=1 AND BARSLAST(MA(C,250)<=REF(MA(C,250),1))>=1 AND MA(C,20)>MA(C,250),MA(C,250),DRAWNULL)COLORMAGENTA LINETHICK5;

NO2:=REF(IF(REF(V>=REF(V,1)*1.87 AND C>=(REF(C,1),O) AND TOPRANGE(V)>=20,1) AND L>REF(O,1),REF(O,1),REF(IF(L>REF(H,1),REF(H,1),O),BARSLAST(FILTER(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H AND IF(RANGE(BARSCOUNT(V),20,250), COUNT(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H,8)=1,COUNT(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H,20)=1 AND (CROSS(MA(C,20),MA(C,250)) AND C/MA(C,250)< 1.15 OR CROSS(C,MA(C,250))))=1,5)))),BARSLAST(FILTER(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H AND IF(RANGE(BARSCOUNT(V),20,250), COUNT(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H,8)=1,COUNT(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H,20)=1 AND (CROSS(MA(C,20),MA(C,250)) AND C/MA(C,250)< 1.15 OR CROSS(C,MA(C,250))))=1,5)));

NOD:=REF(IF(REF(L,1)>REF(H,2),REF(H,2),NO2),BARSLAST(FILTER(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H AND IF(RANGE(BARSCOUNT(V),20,250), COUNT(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H,8)=1,COUNT(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H,20)=1 AND (CROSS(MA(C,20),MA(C,250)) AND C/MA(C,250)< 1.15 OR CROSS(C,MA(C,250))))=1,5)));

DRAWKLINE(H,O,L,C);

STICKLINE(REF(O,1),REF(IF(REF(L,1)>REF(H,2),REF(H,2),NO2),BARSLAST(FILTER(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H AND IF(RANGE(BARSCOUNT(V),20,250), COUNT(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H,8)=1,COUNT(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H,20)=1 AND (CROSS(MA(C,20),MA(C,250)) AND C/MA(C,250)< 1.15 OR CROSS(C,MA(C,250))))=1,5))),REF(IF(REF(L,1)>REF(H,2),REF(H,2),NO2),BARSLAST(FILTER(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H AND IF(RANGE(BARSCOUNT(V),20,250), COUNT(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H,8)=1,COUNT(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H,20)=1 AND (CROSS(MA(C,20),MA(C,250)) AND C/MA(C,250)< 1.15 OR CROSS(C,MA(C,250))))=1,5))),2,0),COLOR404080;

STICKLINE(H,REF(O,BARSLAST(FILTER(TOPRANGE(V)>=20 AND C< O AND L<=REF(H,1),3))),REF(O,BARSLAST(FILTER(TOPRANGE(V)>=20 AND C< O AND L<=REF(H,1),3))),1,0),COLORBLUE;

STICKLINE(H,REF(C,BARSLAST(FILTER(TOPRANGE(V)>=20 AND C>=O AND C>=REF(C,1),1))),REF(C,BARSLAST(FILTER(TOPRANGE(V)>=20 AND C>=O AND C>=REF(C,1),1))),1,0),COLORLIGRAY;

STICKLINE(V>=REF(V,1)*1.87 AND C>=(REF(C,1),O) AND TOPRANGE(V)>=20,O,C,3,0)COLORBLUE;

STICKLINE(V/REF(V,1)>=2.9 AND C>=O AND TOPRANGE(V)>=20,O,C,(-1),0)COLORMAGENTA;

STICKLINE((C-REF(C,1))/REF(C,1)*100< IF(CODELIKE('68'),-9.0,-6.9) AND (C-REF(C,1))/REF(C,1)*100< IF(CODELIKE('30'),-9.0,-6.9),O,C,(-1),0),COLORGREEN;

STICKLINE((C/REF(C,1)-1)*100< IF(CODELIKE('68'),-9.0,-6.9) AND (C-REF(C,1))/REF(C,1)*100< IF(CODELIKE('30'),-9.0,-6.9) AND H< REF(L,1),O,C,(-1),0),COLORBLACK;

STICKLINE((SUM(AMOUNT,1)/SUM(V,1)/100>REF(C,1) AND C<=O) OR (SUM(AMOUNT,1)/SUM(V,1)/100>REF(C,1) AND C>REF(C,1) AND C< O AND C>300) AND NOT((C-REF(C,1))/REF(C,1)*100>=9.71 AND O=C) AND NOT((C-REF(C,1))/REF(C,1)*100<=-9.71 AND O=C) AND NOT(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H) OR AMOUNT/V/100< REF(C,1) AND C>O AND C< 300  AND SUM(AMOUNT,1)/SUM(V,1)/100< REF(C,1) AND NOT((C-REF(C,1))/REF(C,1)*100>=9.71 AND O=C) AND NOT((C-REF(C,1))/REF(C,1)*100<=-9.71 AND O=C),MIN(O,C),MIN(O,C)+(MAX(O,C)-MIN(O,C))*0.5,1,0)COLORFF80FF;

STICKLINE(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H,O,C,(3),0)COLORRED;

STICKLINE((O-C)/O>0.02 AND C< REF(C,1),(C+O)/2,(C+O)/2,2,1)COLORCYAN;

STICKLINE((C-O)/O>0.02 AND C>REF(C,1),(C+O)/2,(C+O)/2,2,1)COLORCYAN;

STICKLINE(TOPRANGE(V)>=88 AND C>O,(MAX(C,O)-MIN(C,O))*0.50+MIN(C,O),C,(-1),0)COLOR4080FF;

STICKLINE((H-REF(C,1))/REF(C,1)*100>IF(CODELIKE('68'),19.71,9.71) AND (H-REF(C,1))/REF(C,1)*100>IF(CODELIKE('30'),19.71,9.71) AND C< H,MAX(C,O),MAX(C,O)*0.995,(2),0)COLORBLACK;

DRAWICON(FILTER(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H AND IF(RANGE(BARSCOUNT(V),20,250), COUNT(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H,8)=1,COUNT(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H,20)=1 AND (CROSS(MA(C,20),MA(C,250)) AND C/MA(C,250)< 1.15 OR CROSS(C,MA(C,250))))=1,5),H+0.05,9)DRAWABOVE;

DRAWTEXT(REF(O,BARSLAST(FILTER(TOPRANGE(V)>=20 AND C< O AND L<=REF(H,1),3)))>0 AND CURRBARSCOUNT=1,REF(O,BARSLAST(FILTER(TOPRANGE(V)>=20 AND C< O AND L<=REF(H,1),3))),'    高量阴') DRAWABOVE COLORBLUE;

DRAWTEXT(REF(C,BARSLAST(FILTER(TOPRANGE(V)>=20 AND C>=O AND C>=REF(C,1),1)))>0 AND CURRBARSCOUNT=1,REF(C,BARSLAST(FILTER(TOPRANGE(V)>=20 AND C>=O AND C>=REF(C,1),1))),'    高量阳') DRAWABOVE COLORLIMAGENTA;

DRAWNUMBER(REF(O,BARSLAST(FILTER(TOPRANGE(V)>=20 AND C< O AND L<=REF(H,1),3)))>0 AND CURRBARSCOUNT=1,REF(O,BARSLAST(FILTER(TOPRANGE(V)>=20 AND C< O AND L<=REF(H,1),3))),       REF(O,BARSLAST(FILTER(TOPRANGE(V)>=20 AND C< O AND L<=REF(H,1),3)))),COLORBLUE;

DRAWNUMBER(REF(C,BARSLAST(FILTER(TOPRANGE(V)>=20 AND C>=O AND C>=REF(C,1),1)))>0 AND CURRBARSCOUNT=1,REF(C,BARSLAST(FILTER(TOPRANGE(V)>=20 AND C>=O AND C>=REF(C,1),1))),       REF(C,BARSLAST(FILTER(TOPRANGE(V)>=20 AND C>=O AND C>=REF(C,1),1)))),COLORLIMAGENTA;

板底:IF(CURRBARSCOUNT<=CONST(REF(BARSLAST(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H AND IF(RANGE(BARSCOUNT(V),20,250), COUNT(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H,8)=1,COUNT(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H,20)=1 AND (CROSS(MA(C,20),MA(C,250)) AND C/MA(C,250)< 1.15 OR CROSS(C,MA(C,250))))),1)+1)+1,CONST(REF(NOD,REF(BARSLAST(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H AND IF(RANGE(BARSCOUNT(V),20,250), COUNT(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H,8)=1,COUNT(((C/REF(C,1))-1)*100>IF(CODELIKE('68') OR CODELIKE('30'),19.71,9.71) AND C=H,20)=1 AND (CROSS(MA(C,20),MA(C,250)) AND C/MA(C,250)< 1.15 OR CROSS(C,MA(C,250))))),1)+0)),DRAWNULL),COLORMAGENTA,LINETHICK2;

{DRAWGBK(DATE>1231231,RGB(0,255,0),RGB(255,0,0),0,0,0); 

高阳:IF(CURRBARSCOUNT<=CONST(REF(BARSLAST(FILTER(TOPRANGE(V)>=20 AND C>=O AND C>=REF(C,1),1)),1)+1)+1,CONST(REF(REF(C,BARSLAST(FILTER(TOPRANGE(V)>=20 AND C>=O AND C>=REF(C,1),1))),REF(BARSLAST(TOPRANGE(V)>=20 AND C>=O AND C>=REF(C,1)),1)+1)),DRAWNULL),COLORRED,LINETHICK2;

高阴:IF(CURRBARSCOUNT<=CONST(REF(BARSLAST(TOPRANGE(V)>=20 AND C< O AND L<=REF(H,1)),1)+1)+1,CONST(REF(REF(O,BARSLAST(FILTER(TOPRANGE(V)>=20 AND C< O AND L<=REF(H,1),3))),REF(BARSLAST(TOPRANGE(V)>=20 AND C< O AND L<=REF(H,1)),1)+1)),DRAWNULL),COLORBLUE ,LINETHICK2;

注:

       馆内各种公式为学习编程而保存,实战使用前一定要看其中是否有未来函数并自己亲自测试成功率,决不能依据公式名称的描述和形容去投资,据此入市造成投资损失由投资者自己承担。

       发文不易,如获益,欢迎赞赏,赞赏必复!

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。